Welcome! Log In Create A New Profile


I need help fixing an iPod 5th gen (iPod Video) [Fixed]

Posted by bg4545 
I need help fixing an iPod 5th gen (iPod Video) [Fixed]
October 05, 2010 05:00AM
I know this is kind of random but I was wondering if anyone had any insight on this.
So a while ago I acquired a broken 30GB iPod Video (5th gen, not 5.5). It was broken in that when it booted it would show a sad iPod icon . Searching around, I found out that this can be due to a bad hard drive. Sure enough, booting into the hardware diagnostic mode on the iPod revealed that the hard drive was indeed busted. (Whenever I attempted to test the hard drive it would freeze showing no result.)
So when I figured it out I knew I would need to get a new replacement hard drive which is not hard to find. I finally got around to getting in and I just received it today. I proceeded to disassemble the iPod and replace the hard drive. All went fine, and even the hardware diagnostic shows 30GB hard drive and is successful.
Here's the problem, booting the iPod it shows this:

A simple restore should do the trick right? Turns out it's not that easy. I plug in the iPod and it goes to "Disk Mode" but it is not recognized by iTunes or My Computer (on Vista). It does, however, have a drive letter (F:) but trying to open it or right-click it crashes Windows Explorer. I even tried running the Disk Manager to try formatting it there but that freezes as well On my other PC (XP), Properties shows that Windows cannot detect the filesystem. On my Ubuntu partition the iPod is not detected at all. I've tried (on my Vista PC) to run a command prompt and run "format F: /FS:FAT32" but it doesn't work. It says drive is "RAW" formatted and it cannot get cluster size or something like that.
So basically my computers can't read whatever format the disc is and just crashes when trying to do anything with it. I don't think it's the iPod's fault as it detects the hard drive itself perfectly fine and disk mode works. So I'm not really sure what to do from here.

EDIT: I've also tried it in Mac OS X (Hackintosh) and it's not shown in Disk Utility. It can't be the USB cable because it works perfectly with my other iPods (nano 2g and touch 1G).

Edited 2 time(s). Last edit at 10/07/2010 06:03AM by bg4545.
Re: I need help fixing an iPod 5th gen (iPod Video)
October 05, 2010 08:16AM
Well nevermind; I still don't know what the problem was but after leaving it plugged in eventually OS X picked it up as a corrupted iPod and I was able to restore it.
Sorry, you can't reply to this topic. It has been closed.