Welcome! Log In Create A New Profile


4.1U Strange Brick

Posted by dchain 
4.1U Strange Brick
February 12, 2011 08:35AM
To provide some context before the problem:

I was running 4.1U and was following the basic bannerbomb process. BootMii installed fine, as well as HBC. I restarted the Wii, and BootMii was there. I figured everything was fine and went to load a game...black screen (frozen). I restarted the Wii and BootMii didn't appear, but the console booted up as normal. Tried HBC...black screen. So I figured why not reformat the wii system memory (probably a huge mistake)? So I did, let the reformat run, restarted and tried to load a game...black screen.

So, here's the problem: I don't know what happened to BootMii (as it won't load now for some reason). I can't load games, run the bannerbomb, or even smashstack in order to try and reinstall HBC or BootMii because it freezes at a black screen. Strange enough though, the System Menu loads fine and I can access all of the menu options. Trying to load a game or install anything results in a frozen black screen though.

Any idea what's going on and how to fix it? I'm pretty confused. Thanks in advance.


Got BootMii working. Trying to figure out what to do next. (Really wish I could go back in time and make a NAND backup).

Edited 1 time(s). Last edit at 02/12/2011 09:05AM by dchain.
Re: 4.1U Strange Brick
February 12, 2011 11:07AM
Fixed it!

So yes, technically the problem is resolved now. However, it took about 3 hours of my life to figure out what went wrong. I figure I can help save other people a headache if they run into a similar problem. Anyways, here's how I resolved it:

Problem: Unable to run the latest bannerbomb or smashstack. Specific games (Brawl and MKart Wii) don't load. Homebrew dissapeared.

After doing a lot of searching I found ModMii, a very cool utility that made fixing this possible. Using it I generated the necessary files to put on my SD card by choosing "Homebrew Fix". By doing so I was able to run the bannerbomb (finally) and get Homebrew back on the Wii. Yes, this step was huge. ModWii also included the Homebrew app "Multi Mod Manager".

Now with MMM at my disposal I was able to investigate what ISOs were active and installed. Using the ISO browser I was able to see that ISO36 (it even told me this ISO is used for brawl, MK: Wii, and homebrew) was the problem. So how did I fix it? Using a utility I found called "NSU Downloader". Using it I was able to get access to a healthy ISO36 WAD, put it on my SD card, and used MMM to install the WAD and the corrupt ISO36 was patched.

So, in closing, MMM is a great debug/repair tool. Get it. Use it. Check the ISO Browser and see if any problems you are having relate to any of the ISO descriptions (mine was with 36). Relating back to my original problem, I'm guessing the Homebrew installation messed up and my ISO36 got corrupt somehow.

PS: The second you get BootMii running do a NAND backup! I'm doing this right now. It will save you a lot of time and frustration if you do it. I'm sure in the future I'll be happy I backed it up in case this happens again. If anyone has any questions just ask.

Don't link to gbatemp, and don't mention ModMii or MMM again on these forums. --bg4545

Edited 1 time(s). Last edit at 02/12/2011 09:53PM by bg4545.
Re: 4.1U Strange Brick
February 12, 2011 01:41PM
Wiibrew prefers using DOP Mii instead of MMM, as MMM can be used for piracy wheras DOP Mii cannot. Also, ISO =/= IOS. An IOS is kind of like a driver for your Wii, whereas an ISO is like taking the contents of a dvd and squeezing it into one file.
Sorry, only registered users may post in this forum.

Click here to login