Welcome! Log In Create A New Profile Wiibrew Wiki HackMii Blog

Advanced

Semi-bricked wii, help needed!

Posted by sensorplus 
Semi-bricked wii, help needed!
November 30, 2011 06:02PM
Earlier this year my Wii was semi-bricked most likely from a Nintendo update. I have boot2 installed as bootmii so when I turn on the wii it loads that menu first. From there I am able to go to the system menu or the homebrew channel. Unfortunately I do not have a NAND backup so I am unable to restore my Wii from one. From the system menu, if I try to go to the system settings or any channel(via the system menu) I get the "The System Files Are Corrupt. See The Operations Manual For Assistance" error. When I access my Wii's save files, all files have a "?" as the icon and I am unable to copy or save any of the data, even when using the "remove copy protection" hack. In hopes of fixing my Wii, I had downgraded from 4.3U to 4.1U using a downgrade wad. Before the downgrade I had preloader/priiloader but I do not anymore although I assume I would be able to install it from accessing the homebrew channel via the bootmii menu. I had been trying to update my Wii via the official Wii Nintendo Updater in the system settings but since I can't access the settings I had to find other ways to do so. When I ran the rebooter in Gecko with a Wii disc in, the disc channel would ask me to update(the same disc previously didn't ask me to update if I didn't use the rebooter) so I did. Then I tried the rebooter with a newer disc so the disc channel asked me to update again so I updated from the disc again. I tried to insert an update disc through the Gecko hombrew app that I thought had 4.3U on it but when I tried to run it I got the "DSI Erorr" everytime. I later found out that the disc contained the update for 3.2U. I then tried inserting a burned copy of a gamecube game for testing purposes. Each time that I tried to run it, Gecko would try to start the disc but a few seconds later it would restart the Wii, bypassing the bootmii menu. Some of the times that I tried this, the Disc Channel would show the icon for a regular gamecube game, but sometimes it would not. On the times that it did, I tried to load up the game from the disc channel. A couple seconds after clicking "Start Game" it would go to a black screen and stay there while the Wii's power light stayed on. I then tried inserting a burned copy of a Wii game that is new enough to require 4.3U so it asked me to update so I did. About a half hour later it finished updating to 4.3U but I still had the same problems as before(system files are corrupt when trying to access settings). When I went to Gecko after that update I noticed that there were less options in the main menu. Rebooter, Launch Channel and others were gone with only Launch Game, Options and About being the only remaining menu options. When I tried each of my 3 discs(my 3.2U update disc, burned GC game and burned Wii game) each of them said "No DVD Found." A few side notes: My Wii's internet connection settings were set to connect to a friend's internet. Since accessing Wii maintenance mode is my only way to access the settings, I turned this on and went to internet connection settings to try to change it to connect to my internet at home. I got an error message that, when I looked it up online on Nintendo's support site, said to call Nintendo. While they were trying to help me connect to the internet after I explained how I got the error message, the person on the phone told me to erase all connection settings so I did. Later I found out that maintenance mode disables WiiConnect24. Before and after my downgrading and updates all of my save files were accessible except one. When I loaded the games whose save files were fine via Gecko, the save file loaded as normal. The only save file that doesn't work is the one for Super Smash Bros Brawl. The save file is located in the Wii System Memory as normal and is taking up the amount of space it should(about 124 blocks) but when I load the game via Gecko it says that no save file is found and is asking me to create a new one. I do not wish to format my wish since no mode of backing up my saves is known to me so far. I prefer to not send it in to Nintendo since I am worried they won't be able to save all of my save files, including Brawl. I have no way to connect my Wii to the internet. I do have full access to the homebrew channel and bootmii but no NAND backup. Any suggestions on what my Wii's problem is and/or a possible solution would be appreciated!
Re: Semi-bricked wii, help needed!
December 01, 2011 09:08PM
Ever heard of a paragraph? Might encourage people to read what you wrote and help ;)

Anyway, seems like you installed an out-of-region update, or else messed with your region settings in something like AnyRegion Changer.

Fixing it shouldn't be too hard, but you may well have made it worse by the dozens of things you listed you did.

My advice would be to run AnyRegion Changer and check that all the region settings are set to the correct region for where you live (i.e. for you they should be USA) then exit AnyRegion Changer and use DOP-Mii to install the latest System Menu for your region (4.3U) as well as IOS80 (you might already have this, but make sure). This should fix your problems.

Before doing ANY of this though, take a BootMii NAND dump of your Wii as it is now. Also, FYI, a format would do NO good, and in fact probably just make things worse.
Re: Semi-bricked wii, help needed!
December 01, 2011 09:18PM
I'm actually not sure what caused my problem since my friend was borrowing my Wii at the time that the problems started occurring. WhenI ran the burned Wii game that required the Wii System update, that updated my system to 4.3U. Using DOP-Mii, I checked and it said that I do have IOS80 installed. I tried installing Priiloader and I was successful in doing that. Then, using Wad Manager I tried installing a wad for 4.3U. The only notable difference this caused is removing Priiloader. I am assuming that at this point my only remaining option is to try using Betwiin (http://wiibrew.org/wiki/Betwiin). Am I correct? Or is there a simpler alternative?
Re: Semi-bricked wii, help needed!
December 03, 2011 07:11AM
Load bootmii and make a new nand backup, extract the nand.bin to your had with showmiiwads or similar tool. Then use ohneswanzenegger to format your new nand.bin (make a backup copy first), then install sm 4.1 with ohneswanzenegger, then restore the nand.bin with bootmii. You can then pull your savegames from your extracted nand bin and restore them to your wii, or you can backup them up before you start with save game manger.

Alternatively, since you can access the settings via maintenance mode, doing a system format may fix your issue, but with your luck it will probably hang. I think your region settings are fine, since you should still have a region miss match with the maintenance mode, so you have some system corruption unrelated to your sm or sm ios.

ohneswanzenegger should set you strait.

Also you may wish to exclude and mention of wads, burned disc, etc in your future posts.



Edited 1 time(s). Last edit at 12/03/2011 07:11AM by mauifrog.
Re: Semi-bricked wii, help needed!
December 07, 2011 04:06AM
How do I extra t the savegames from my NAND? And what did you mean by "to your had"?
Re: Semi-bricked wii, help needed!
December 07, 2011 03:02PM
You can extract them from your wii with savegame manager
Or you can extract a nand.bin with showmiiwads, then pull the savefiles from that and restore with savegame manager.
Re: Semi-bricked wii, help needed!
December 07, 2011 04:46PM
Can you please explain exactly how to pull the save files from my nand.bin with showmiiwads? I tried to do this but I couldn't find the right spot in the menu to do that
Re: Semi-bricked wii, help needed!
December 09, 2011 02:01AM
Ask krafter on hacksden, he has a tool that will do it for you auto like.
Re: Semi-bricked wii, help needed!
December 09, 2011 11:09PM
Re: Semi-bricked wii, help needed!
December 09, 2011 11:12PM
I really appreciate all the help that you've given me so far. But I was wondering, do you know of a way to fix my old NAND so that I can use it? I noticed that if I use the NAND that was formatted and then had 4.1 installed on it, my mii's, channels, friend codes, etcs will also be gone. I know which blocks are bad on my NAND.
Sorry, only registered users may post in this forum.

Click here to login