Welcome! Log In Create A New Profile


Trouble installing whiite (filesystem issue?)

Posted by noshroud 
Trouble installing whiite (filesystem issue?)
April 11, 2011 10:38PM
Originally I tried the gui installer. When it came to partitioning my sd card it would allow me to make the first (fat) partition, while allocating the "rest" for the linux filesystem. Problem is that for some reason it decided the "rest" was huge, a million MB or more.

So I tried the manual install; I have:

SD card with a Fat and Ext3 partition
Fat partition has
Mike5 in the bootmii folder (for bootmii launch)
whiite in the apps folder (for IOS launch)

Linux partition has
I untarred that file into this partition and have 22 items that look like a linux filesystem

I have tried loading bootmii and choosing the mike5 kernel. I has trouble loading the filesystem, can't seem to find it, then reboots after 180 seconds

When I launch the kernel in IOS mode under the HBC I get farther. I'm able to login and see the wifi config tool, but it crashes when I run it.

Is there a problem with my installation ? Is there a place where I needed to name the partitions something specific?

Please tell me if you need more info.

A secondary question; will I be able to use get ap to install a gui so I can use firefox? Is there a better way to get a decent internet browser?

Thanks :)
Re: Trouble installing whiite (filesystem issue?)
April 12, 2011 06:25PM
Check out the ext3 partition flags to see if it is:
* Active
* Boot

Other solution, try using an ext2 partition (worked for me)

Regarding the browser, Firefox is too heavy to load on wii hardware, try Icewasel, is lighter and works as well.
Of course you'll be able to use apt-get to install it (and to update your system and whatever else you want to install)

Re: Trouble installing whiite (filesystem issue?)
April 13, 2011 05:05AM
Regarding the browser, Firefox is too heavy to load on wii hardware, try Icewasel, is lighter and works as well.

What is iceweasel?

Iceweasel is a fork [from Firefox] with the following purpose :

backporting of security fixes to declared Debian stable version.

no inclusion of trademarked Mozilla artwork (because of #1 above)
Beyond that, they will be basically identical. (quoting Roberto C. Sanchez post in debian-devel mailing list)

Also note that iceweasel is NOT Iceweasel from [www.gnu.org].

If you really want a lighter weight browser try: Dillo, Hv3, Kazehakase, Links2, W3M-IMG.
Re: Trouble installing whiite (filesystem issue?)
April 13, 2011 05:55PM
Good idea, i'll check out those settings when I get home.

The only browser out of those I recognize is links (not the 2 part) so I'll check them all out.

Thank you both very much.

Are there any working window managers or basic GUI's?

Thanks again, I'll post my results on your fix for everyone in a couple hours.
Re: Trouble installing whiite (filesystem issue?)
April 13, 2011 06:33PM
Fluxbox works great, I posted a tutorial here: [forum.wiibrew.org]
Re: Trouble installing whiite (filesystem issue?)
April 13, 2011 09:44PM
Ok so fixing the flags didn't help when loading via BootMii; however, I now seem to have a working system when loaded through the HBC.

Does this mean that I am using the wrong kernel image from BootMii?

I have Mikep5~NTSC 480p.elf in my bootmii folder on the fat partition.

The error I am receiving is kernel panic unable to load FS

Re: Trouble installing whiite (filesystem issue?)
April 14, 2011 04:01AM
I thought I'd add;

I did all the Linux work using Puppy and it's default GUI. I read that you are automatically logged in as root so I figured there should be no problems with the untarring of the filesystem.

I have all the files (22) on the linux partition, not in a folder or anything. Is this correct?
Re: Trouble installing whiite (filesystem issue?)
April 14, 2011 05:24PM
I did de Linux part using Ubuntu Live CD, try using an ext2 partition instead of an ext3
Re: Trouble installing whiite (filesystem issue?)
April 14, 2011 08:20PM
Thanks, I did switch it to an ext2. No luck.

Why would it be working fine when booted as an IOS but not when booted through bootmii?

Maybe it's not the filesystem but how I installed the Mike kernel? All I did was put it in the bootmii folder, though I did download and do that on a windows machine.

Thanks again
Re: Trouble installing whiite (filesystem issue?)
April 14, 2011 08:39PM
OK, here's a guess
When loading from HBC you use only one file which "decides" which of Mike's Kernel is suitable for your Wii

IOS auto mikep5-zImage-2.6.32.ios.elf

If you want to boot it from Bootmii you need to know which one of ther kernels is suitable for you, and the only way to do that is to try them all:
mini 480i PAL (60Hz) mikep5-zImage-2.6.32.mini.480i(PAL60).elf
mini 576i PAL (50Hz) mikep5-zImage-2.6.32.mini.576i(PAL).elf
mini 480p PAL (60Hz) mikep5-zImage-2.6.32.mini.480p(PAL).elf
mini 480i NTSC (60Hz) mikep5-zImage-2.6.32.mini.480i(NTSC).elf
mini 480p NTSC (60Hz) mikep5-zImage-2.6.32.mini.480p(NTSC).elf

Have you done that already?

Once you know which one works through Bootmii, you can have a dedicated SD card for Wii Linux, rename the kernel file to ppcboot.elf, and place it on a Bootmii folder in the fat partition. Having done that, when you run bootmii it will directly boot into wii linux
Re: Trouble installing whiite (filesystem issue?)
April 15, 2011 02:22AM
I've tried both the NTSC options. I know my TV operates in interlaced mode, so it ought to be the 480i for ntsc kernel. I'll try the pal options tonight.

I figured the wrong kernel would most likely result in a display issue?

I now have access to another flash drive, so I'm going to try the gui installer with that tonight as well.

Re: Trouble installing whiite (filesystem issue?)
April 15, 2011 03:45AM
arg... hehe. New flash card didn't work at all; the installer couldn't see the files.

I repartitioned an external usb hard drive so I had a small partition to put the bundle on for the GUI installer. This actually worked, and I was able to play with the config file so I could install the debianlenny 5.0 filesystem

The correct file counts are 12380 and 5 for the filesystem and kernall tarballs btw.

But still, I cannot get it to load properly through bootmii.

Could there be something wrong with my bootmii installation?
Re: Trouble installing whiite (filesystem issue?)
April 15, 2011 02:07PM
Who knows? I did several installations of Wii Linux: Whiite 4.0, Whiite 5.0, X-Whiite, some of them worked, some other didn't, and sometimes a version that did not work, worked perfectly the second time I performed the install.
I've no clue as to why this happens since I'm kinda a newbie to the linux world.
Still I have a modified Kernel which supports external USB drives (recompiled by myself) which I could pass on to you if you wanna give that a go.
Send me a PM in case you want it.
Re: Trouble installing whiite (filesystem issue?)
April 16, 2011 08:47PM
Thanks, I'll keep fidddlin with it....

Is the purpose behind the kernel you have to install the filesystem onto a USB flash drive/external HD?

Does the kernel go there as well?

Thank you for all your help
Re: Trouble installing whiite (filesystem issue?)
April 18, 2011 04:22PM
My final purpose was to achieve DVD Playback through an external DVD player (I'm MILES away from there yet, but at least the drive is properly recognized, I'm still having issues with xine-ui).

The kernel files provided by the GC-Linux team don't support external USB DVD units, that's why I had to recompile it. Yet, I'm pretty sure it does support USB flash drives as is, so the original version should work for you (although I didn't try it, so I can't really tell).

Nevertheless, if you wanna give my kernel a go, let me know, it might help you
Re: Trouble installing whiite (filesystem issue?)
May 06, 2011 09:56PM
Sorry I fell off for a minute there...

Tried your kernel, still nothin...

Been playing with puppy linux/arcade; if only the wii had more ram :)
Sorry, only registered users may post in this forum.

Click here to login