Welcome! Log In Create A New Profile


I can't get Wiiware/VC cheats to work

Posted by Kane123 
I can't get Wiiware/VC cheats to work
March 04, 2010 06:34AM
I have a newer model Wii updated to 4.2U and I cannot for the life of me get cheats to work on wiiware/virtual console games (although I only tried virtual console games so far.) I'm using Gecko OS ( and recently restored the load channel and reboot features using the Trucha Bug Restorer. I did not use Dop-Mii if that matters to anyone. I also just started using Cheat Manager and Code Downloader because I was getting tired of always taking my SD card out of my Wii to put codes on it using my PC. Anyway, both programs work fine, I can download codes fine, create GCT files fine, load channel work fine, it says the game id and apply SD codes and the games load fine. However, the game just plays normally and the cheats that I applied have no effect whatsoever on the games I tried. I have all the appropriate folders I need on the root of my SD card (txtcode folder, code folder) as well. I was told from the Wiird forum to come here for help. If it helps, Gecko OS says it's using IOS61 v21.29.
Re: I can't get Wiiware/VC cheats to work
March 04, 2010 07:08AM
Try different games, with different codes. I was actually in a similar position earlier, I was looking for a way to get Gecko to run a Wiiware game, and I used your post as a guide to that :P So, you did the preliminary steps right, I was able to get Mega Man 10 codes to work.
Re: I can't get Wiiware/VC cheats to work
March 04, 2010 07:48AM
The folder on the SD card needs to be called "codes" not "code."

What games are you playing? What cheats are you applying? Are you using the correct region?
Re: I can't get Wiiware/VC cheats to work
March 04, 2010 03:53PM
Sorry, it does say "codes", not "code." I live in North America so I'm using NTSC-US codes. The only games I've tried so far are Phantasy Star II and Golden Axe (Genesis version) and using your most common cheats like infinite health and such.

UPDATE: Today, I tried Golden Axe II and the codes for that didn't work. I decided to try my first Wiiware game so I tried Mega Man 9. I tried Infinite Health on that. The game loaded and I started playing and...the code works! And that's all I've done so far. Mega Man 9 is the only one so far that had a working code. All the virtual console game have yet to work. I hope there's a solution to this. I'd appreciate any help I can get.
Re: I can't get Wiiware/VC cheats to work
March 04, 2010 06:12PM
I ran into a similar issue, I am sorry that I forgot about it until now but the pieces didn't fit until MM9 worked. Take you SD Card out and put it in your PC. Open one of the offending VC game's txtcodes files and check 3 things:

1. That the saved file name with spaces included is less than or equal to 24 characters in length.

2. That the game id is 4 digits only, ends in E, is in all CAPS, and that the following game name line is directly below it with no blank lines between and only 1 blank line between it and the first code title. Also the game name should only contain letters, numers, and spaces no other characters of any kind.

3. That there are no spaces between the left margin and the first digit in the codes or their titles.

I have had some games have messed up formatting of the txtfile from codedownloader but it has always been VC games and it has happened to me and 2 other people, you would make 3 if it is indeed the issue. For some reason it always affects all code files downloaded for VC games on a set date so check the file date in Windows mode as it is likely that if this is the issue for this game then it will happen for any other VC games you got codes for on that day. I have a post about this up over at Wiird but like I said the pieces didn't fit until MM9 worked.

If you check and this is not your problem then come back and let us know and we will see what we can do about it. The others that are smarter than me should be on in the next 1-2 hours or so, from the time of this post 12 Noonish EST. Hope this helps. Best of luck to you. Talk to you later.

Re: I can't get Wiiware/VC cheats to work
March 04, 2010 07:19PM
I think I found the reason why the codes don't work although it's sort of hard to explain unless you download the text files from geckocodes.org on your PC and see for yourself. I checked a few text files for a few other systems and I guarantee they'll work before I even try them. First download the text file for MegaMan 9, or any Wiiware title I suppose. Now download a text file from any Sega Genesis game.

The Sega Genesis text files are all neatly lined up along the left margin. The characters in the text files for all the other systems I checked (not just Wiiware) are all jumbled along the top and are a complete mess, but that seems to be the reason why they work. I am 99.99% sure that this is the reason why Phantasy Star II and Golden Axe (both Sega Genesis games) codes do not work. Somebody will have to fix all those Sega Genesis text files on the site.
Re: I can't get Wiiware/VC cheats to work
March 04, 2010 08:21PM
Well its the reverse of what should be the case but if it works, go with it, I always say. Glad to hear you found the root of the problem. You know if you study the "mess" close enough on several different games you will be able to devise the pattern that makes it work for your system and reset the txt files for your Sega games so that they are a "mess" too and will work as well.

I gotta say it isn't logical as alinging on the left margin is what should make the codes function, is word wrap off by chance, just shooting in the dark here. All my codes work and are formatted like this:

Super Mario Brothers

Invincible (hacker)
xxxxxxxx yyyyyyyy

Have Everything
xxxxxxxx yyyyyyyy

Save Anywhere
xxxxxxxx yyyyyyyy
The lines indicate the files edges, then the file would be saved as Super Mario Bros.txt

That is how a properly formatted txt codes file should look. But as I said earlier. If it works go with it. Hope you get your Sega Game codes lined out. Perhaps GMO or Skiller or one of the other guys over on the Wiird forums will be able to help you figure out how to format them so they work with your system. Later.

Re: I can't get Wiiware/VC cheats to work
March 05, 2010 04:52AM
I tried changing the text files of a Sega Genesis games to be like all the other text files only the cheat manager considers the file empty and no codes show up to be activated. *sigh* It seems I'm the only one with this whole problem. Oh well, I guess I'll check back at the Wiird forums. Thanks for your help, Elmoreas.
Re: I can't get Wiiware/VC cheats to work
March 06, 2010 03:56PM
Another Update:

I actually got Golden Axe II and Golden Axe III (Genesis games) cheats to work so there must be something with the codes to Phantasy Star II.
Re: I can't get Wiiware/VC cheats to work
March 29, 2010 02:00AM
Sounds like it might be because of the differences between a Windows and Linux formatted text file (they use slightly different indicators for the end of a line of text).
Assuming you're on Windows, get a good text editor (I use and suggest Notepad++, it's free and awesome). This should basically allow you to work with text files in both 'formats'. Also, IIRC, you can change between formats at will, so save the cheat file in both formats, and test to see if one works and the other doesn't.
Other than that, it's likely to be a syntax/formatting issue, in my experience with this and other text-file based cheat system.
Re: I can't get Wiiware/VC cheats to work
March 29, 2010 11:00AM
It's OK. Another hacker made up his own codes and those work for me.
Re: I can't get Wiiware/VC cheats to work
February 06, 2015 09:45AM
Anyone Tried cheats for castlevania rondò of blood?
It is the only that is no function
Sorry, only registered users may post in this forum.

Click here to login