Welcome! Log In Create A New Profile


Mplayer-Wii Problem with Wired Network - RESOLVED

Posted by KnoWei 
Mplayer-Wii Problem with Wired Network - RESOLVED
January 05, 2009 04:56AM
I've successfully installed Mplayer-Wii. I'm currently using the mplayerwii-agentx[1].r3 download from here: [wiibrew.org]

I have three internet Connection Settings defined in my Wii console.

1 = Wired Connection set for fixed IP
2 = Wired Connection set for DHCP
3 = Wireless Connection set for DHCP

For the wired network I'm using the Datel Wii Lan Adapter.

All three settings successfully test to the NUS server.

From the HBC Application menu the network initializes properly for whichever connection I'm currently set to use (i.e. as set in Wii Settings/Internet/Connection Settings). When I'm in the HBC Application menu I can ping the Wii from a PC on the network regardless of which connection is in use, 1, 2, or 3.

When the Wireless connection is active (Connection 3), I load Mplayer using HBC and then I select an SMB share, it initiates the network, connects and shows me the IP address, and successfully streams an avi file from an SMB share across my wireless connection.

But when I use either of the wired connections (1 or 2) the Mplayer attempts to initialize the network (per status at the bottom) and then returns with "Unable to initialize network".

I've tried this with only one wired connection defined (i.e. no second wired or wireless in Wii Settings/etc.) and that doesn't help.
I've tried moving the Lan adapter to the second USB port also with no difference in symptoms.

If anyone is running Mplayer-Wii and succesfully streaming AVI (or audio for that matter) over a wired connection can you post your particulars please? Which version of Mplayer, which Lan adapter, etc. This must be something simple I'm overlooking since HBC can successfully initialize the network for all three connection types.


Edited 1 time(s). Last edit at 01/05/2009 05:38AM by KnoWei.
Re: Mplayer-Wii Problem with Wired Network - RESOLVED
January 05, 2009 05:24AM
Found the answer here:


Hate it when I put all that effort into a post and then find an answer.

For those too lazy to click here's the answer thanks to "rodries"... :-)

[With Wii powered down]
1- Unplug usb ethernet
2- power on wii
3- open mplayer wii
4- when menu is shown plug usb ethernet

Wired connection worked after these steps.


Edited 1 time(s). Last edit at 01/05/2009 05:37AM by KnoWei.
Sorry, only registered users may post in this forum.

Click here to login