Welcome! Log In Create A New Profile


The ol' USB App loader from within HBC - Hopefully? Solved

Posted by Schemer717 
The ol' USB App loader from within HBC - Hopefully? Solved
August 22, 2012 02:12PM
Having just installed HBC onto my Wii (Albeit nervously) I then used a friends SD card to run applications from within HBC. This was great until I decided that I would use my USB to load the apps instead of an SD. Lo and behold... an error that most people seem to be getting... no apps from USB. It lit up properly on pressing (1) and my usb has a flashing light on it when its being accessed but no Apps?

Sorry, I know this is rather long winded but there is a point ;)

Having used a program called MiniTool Partition to partition the SD card into 2 4gb partitions (It was an 8gb one and fat 32 dont recognise them properly!) I then used it to -standard- format my usb to fat32.

With regard to loading apps in HBC this is what happens.

1) SD Works....
3) SD Card via USB card reader WORKS.

The third in the list threw me completely!

It all lies in how you partition your drives.
In order (from my experience) to get apps to be recognised and indeed load them using HBC they need to be loaded onto LOGICAL PARTITION.
I partitioned my USB as follows...
1) Format WHOLE Drive....
2) Create worlds smallest PRIMARY partition (mine was 14MEG lol)
3) Create SECONDARY LOGICAL FAT32 Partition.
4) Erase 1st partition.
5) Change Drive letter for SECOND partition.
BOOM.... Copy apps folder from PC to USB. (Yeah you lose like 14meg)

I have a 1gb USB Flash drive that now boots apps within HBC. Please let me know if this worked for anyone else out there struggling to load apps via USB.

I am no genius or even profess to know what im doing. I noticed my SD card was using a logical drive and *no pun intended* logically i tried it with my USB ;)

Just in case. My system is a 4.3E Wii with the latest Homebrew Channel and IOS fixes using Letterbomb.
Hope this is a fix even if it is longwinded.
(ADMIN GUYS) Please test this because i havent the know how to fully test it. It worked for me.
Re: The ol' USB App loader from within HBC - Hopefully? Solved
August 22, 2012 02:19PM
@ Forum Mods -- -- -- I did read the forum rules btw ;) .... this topic seemed a little in the grey area as far as general goes. I apologise if you deem it as general but i saw it specifically about HBC apps... technically lol.
Re: The ol' USB App loader from within HBC - Hopefully? Solved
August 22, 2012 10:53PM
It's actually better to use a primary partition rather than a logical one, the ability to mount logical partitions didn't always exist in libfat (which is the filesystem library most homebrew apps use) which means a lot of older apps won't be able to see a logical partition. I don't know why a primary partition didn't work for you in the first place, possibly it wasn't actually formatted as FAT32 (NTFS or exFAT) or it's a very large drive and was using a GPT partition table.
Sorry, only registered users may post in this forum.

Click here to login