Welcome! Log In Create A New Profile


Classic control for snes wii emulator no working

Posted by don1215 
Classic control for snes wii emulator no working
March 14, 2014 11:28PM
when i try to play with the control nothiing happens
can someone help out
Re: Classic control for snes wii emulator no working
June 26, 2015 03:01PM
I'm having the same problem. Here are the specifics:

I have an official Wii Classic Controller Pro (Japanese; black) that works just fine on Virtual Console games, but when trying to play the Snes9xGX, it doesn't work. It will work in the menu of Snes (selecting games, changing options, etc.) but once the rom is loaded, none of the buttons work except the Home button.

I know this is an old issue. I can find several forum posts from about four to five years ago about this. The problem at the time was that the Classic Controller Pro was unsupported, but it usually resulted in someone recompiling the source code. Unfortunately, all the links to their recompiled code are no longer active. On the WiiBrew Wiki, I can see that there was updated controller support for Snes9xGX shortly after these issues were reported. I believe I have the latest version of the software (4.3.2), so if this issue was fixed, I have a different issue. Solutions?

If I need to code it myself, I'd be willing to take a stab at it, but would need some pointing in the right direction to get started.

Thanks, all!
Re: Classic control for snes wii emulator no working
June 29, 2015 04:19AM
The classic controller pro works no differently from the original classic controller, so there's no reason it would be unsupported.
Re: Classic control for snes wii emulator no working
June 30, 2015 03:49PM
After reading your post, I plugged in my controllers exactly the way I did before and everything worked. Conclusion: your words are magic.

Originally, I plugged in the Classic Controller Pro and it wouldn't work on any of the ROMs I loaded. Researching the issue, I was confused because I had misread this forum post. I thought that the CCPro had a different ID than the CC. Rereading that post, I realized that's not the case. I tried different configurations of connecting the CCPro to different Wiimotes and even connecting two CCPros at the same time to see if it caused any problems. Nothing.
Whatever caused my controller to originally not work is making me look foolish now because I can't replicate the issue. A good problem to have, I suppose. :)
Re: Classic control for snes wii emulator no working
July 01, 2015 03:29AM
Technically they do have different IDs, but the code that homebrew programs use for controllers doesn't care because it only checks the last four bytes (out of six) and the difference is in the first.
Sorry, only registered users may post in this forum.

Click here to login