Welcome! Log In Create A New Profile


Unable to get DVD playback on 4.2u

Posted by wiiusehere 
Unable to get DVD playback on 4.2u
March 24, 2010 03:58AM
What I did is:

Take clean wii already updated to system menu 4.2
Use bannerbomb to install hackmii v0.6 to get HBC and DVDX.
Get mplayer (also tried mplayer ce 0.75 and 0.76)
Try to play dvd, it did not work.
I did NOT install bootmii.

After doing more research, it sounds like I might need to get cIOS 202 (which mplayer CE relies on)???? I do not have a USB connection to the wii, so I am not sure about this. The things that I think may be an issue:

1) do I need to install bootmii?
2) do I need cIOS 202?
3) is it possible my wii will not allow any DVD playback (even for store-bought DVDs), and how can I tell?

Also, when the screen hangs while using mplayer, and I click on the home key, I get the following dump:

Playing dvd://.
libdvdread: Using libdvdcss version 1.2.9 for DVD access
libdvdcss debug: opening target `/dev/di'
libdvdcss debug: using Erant's DI API for access
libdvdcss debug: DI: initializing dvd...
libdvdcss debug: DI: waiting for device to become ready...
libdvdcss debug: DI: dvd not ready: 0x4
libdvdread: Could not open /dev/di with libdvdcss.
libdvdread: Can't open /dev/di for reading
Couldn't open DVD device: /dev/di (No such file or directory)
No stream found to handle url dvd://

Please help!!!! I am not so wii savvy, but I can follow clear directions. Thanks!
Re: Unable to get DVD playback on 4.2u
March 24, 2010 04:42AM
Since you have the new DVDx, only MPlayer CE .76 could work. Since that failed, you most likely have a new disc drive that can't play DVDs. If you purchased your wii in the past several months or had the disc drive replaced in that time, that is probably the case. Installing the USB 2.0 cIOS will allow MPlayer CE to play DVDs without DVDx installed, but it won't allow DVDs to be played on wiis with new disc drives.
Re: Unable to get DVD playback on 4.2u
April 25, 2010 12:57AM
I'm actually having a similar problem with my DVD playback. I have a launch Wii that I modded last summer with the BannerBomb and was happily using MPlayerTT since. I updated to System Menu 4.2 because I mistakenly thought that I would need it for the Netflix Disc. All of my Homebrew survived the update fine, but I noticed right away that I lost DVD playback in MPlayerTT. I've re-installed everything (including DVDx), but I haven't been able to get DVDs working again.

I will try working with MPlayerCE to see if that works. I can guarantee, though, that my problem isn't a new DVD drive.

Re: Unable to get DVD playback on 4.2u
April 25, 2010 01:21AM
MPlayer TT is out dated and does not support the new DVDx. I recommend you use WiiMC. However, you will need to install cIOS 202 to play DVDs with it.

Edited 1 time(s). Last edit at 04/25/2010 01:23AM by jbc007.
Re: Unable to get DVD playback on 4.2u
April 25, 2010 08:22PM
That's some handy information. WiiMC worked right off the download. I was able to get the WiiMC version of cIOS 202 installed by using the Trucha Bug Restorer.

WiiMC seems like the Wii homebrew I've been waiting for. Thanks for the help. Good to know there's a good community around WiiBrew.
Sorry, only registered users may post in this forum.

Click here to login