Welcome! Log In Create A New Profile


Semibrick? Wiimote's no longer work/sync at all.

Posted by zebrax0r 
Semibrick? Wiimote's no longer work/sync at all.
October 10, 2010 12:20AM
Hi all.

So - I have a Wii, that has been a trusted Wii and has been through all kinds of changes/episodes/work over time. I've run the HBC on it since day immemorial. We've had good times together. It's a very old release day Wii. DMS type, was the optical drive controller/chipset.

The other day, I went to turn the unit on - and to my sadness (and interest), the Wiimote's no longer synchronise with the unit. Tried every trick in the book to get them to talk to the Wii, but they simply don't seem to cooperate.

* Yes - I've RTFM'ed as far as "resetting" the sync goes.
* Yes - I've isolated it to this Wii. It's not the wiimote misbehaving.
* Yes - I've proven it that the wiimote hardware is fine/functional on other Wii's and my MacBook Pro bluetooth connection.
* Yes - I've done a NAND restore from bootmii of my old NAND and keys - but it seems to have done nothing.

So, I tore the Wii apart, and checked that the BT module was seated correct. Seemed fine.

The wii will still boot up if I press the power button on the wiimote. That's where all control fails however. Sits on the black "warning" screen for 30s to 1 min then loads into system menu, as one would expect. Same behaviour for HBC - no sync of motes.

The reason I believe it's a sw issue (i.e - might be IOS related?) is because if the BT module has failed or is malfunctioning, from what I understand of it, the Wii will not actually complete it's boot path procedure, and it'd simply 'black sceen' based upon the workflow/troubleshooting diagram on this site.

Other information that may be pertinent - the system clock/BIOS clock are waaaaay out of whack. Time is wrong. I am sure this is only a causality of having the CMOS/BIOS battery out of the unit when I took it apart though, right?

Any help/thoughts? As it stands, I'm pretty sure I am "semi bricked" in as much as, a Wii without wiimotes is quite useless ;). Works with the GCN controller in BootMii menu, regardless - but that is where it all ends. If I try to jump into any home-brew from HBC, all apps fail to run/black screen. Currently it's a 4.2E legitimately updated wii (PAL).

Thanks for your time, all.


Edited 2 time(s). Last edit at 10/10/2010 12:32AM by zebrax0r.
Re: Semibrick? Wiimote's no longer work/sync at all.
October 10, 2010 12:59AM
Interesting issue. I recommend you make a NAND backup before doing anything else (if you haven't already). That way, you can keep a backup of all of your data, which you are about to delete.

Use NUS Downloader to download any system menu and its IOS (system menu 4.2 and the oldest revision of IOS 70, for example) and the region select. Make sure that the system menu and region select are correct for your region. It may also beneficial to download IOS 36 (preferably v1042). Have it pack all of these contents into WADs.

Create a folder called wad on the root of your SD card and place these WADs in it. Launch Comex's NAND Formatter and it will format your NAND and install these WADs. Hopefully that will fix it. If it doesn't, there may be a hardware issue (unless something goes wrong with the NAND formatter, which has occasionally been known to happen).
Re: Semibrick? Wiimote's no longer work/sync at all.
October 10, 2010 01:33AM

I now have a screen with a hand holding a Wiimote that says "Press A" to continue. Of course, because the Wiimotes will not sync, I can't press A.

Additionally, the Wii will no longer power up from a Wii mote. They *really* seem dead to the unit now.

I've done a further tear down/put back together. Disconnected the BT module, put it back in etc. Still no love...




Edited 1 time(s). Last edit at 10/10/2010 05:14AM by zebrax0r.
Re: Semibrick? Wiimote's no longer work/sync at all.
October 10, 2010 05:30AM
As you know, a broken bluetooth module would normally prevent the system menu from booting. However, maybe the bluetooth module is not completely dead, but does not function normally (I'm not sure if whether this is possible). You could either immediately replace it and hope that that fixes the issue, or first try a few more things to see if this is software related.

Try restoring the NAND backup from before you ran the formatter and see if you can again turn on the wii with the wiimote. More importantly, launch Gecko OS and use it to run a game. See if you can connect the wiimote in the game. You could also use this to reinstall your setting.txt. If you are unable to launch homebrew applications such as these, PM me and I'll get back to you.
Re: Semibrick? Wiimote's no longer work/sync at all.
October 10, 2010 05:45AM
You've been PM'ed.


Re: Semibrick? Wiimote's no longer work/sync at all.
December 12, 2010 12:49AM

I just wanted to post a follow up to this, for those that were interested/following it, and for those that helped. jbc007 - you in particular.

I *finally* got my BT module shipped over two months late into the country. HK post is...probably the worst thing imaginable.

Regardless, after trying and trying...and trying to get my Wiimotes to sync with no joy, and plenty of back and forth with jbc007, removing/re-installing/stripping/re-injecting an original NAND backup etc etc, I simply gave up and waited for my new BT module.

It arrived last night, and I installed.

SO -I am happy to say that the new BT module fixes my sync problem, and I can once again use my Wii :). So, it was a BT module failure all along.

Now, to the important bit.

I think it's important to realise that the BT module has varying degree's of failure scenarios. There is a block step diagram and a bit of pseudocode kicking around wiibrew.org somewhere suggesting that if the BT module fails, the Wii won't actually get to boot point. It's now my experience that this is a half-truth, and not so clear cut, as I had a perfectly booting wii, with an electronically dead BT module, so all the multi-meters suggest.

Anyway - hope that is of some use to you guys. Thanks to all who helped, especially jbc007, and thanks for having such a great board and resources to help us all, when we need it!

Re: Semibrick? Wiimote's no longer work/sync at all.
December 12, 2010 03:33PM
Thanks for the followup. This knowledge about bluetooth module failure will be useful in the future. Anyway, glad you got it fixed.
Sorry, only registered users may post in this forum.

Click here to login