Welcome! Log In Create A New Profile


No keyboard input in Wii Linux

Posted by Fullmetal5 
No keyboard input in Wii Linux
February 19, 2015 04:54AM
I have been trying to get linux to run on my wii.

For fun I thought I'd try to build my own kernel so I found the most up to date version of the patches used for the wii (here). I then used buildroot to create a cross compiler as well as the target system's root file system.

I gzip'd the root file system into a ramdisk and put it in the kernel, then edited arch/powerpc/boot/wii.dts to have the bootargs = "nobats root=/dev/ram0 rootwait force_keyboard_port=4 video=gcnf:60Hz tv=auto loader=ios quite"

Then I used this cross compiler in combination with the build script that came with the kernel to create the zImage.initrd

When building the kernel I changed the option 'Boot Method' (under Platform Support) to IOS method rather than mini

Finally I executed the kernel from the homebrew channel everything seemed to work and I got to a prompt asking me to login to buildroot. Only one problem, no matter which keyboard port I plugged into I can't get it to recognize my keyboard.

I tried different keyboards, tried changing the option that said force_keyboard_port but nothing could get it working.

Through other methods of testing I've confirmed that the USB ports aren't broken so I'm at a loss for whats going wrong.

Any help is appreciated, Thanks!

P.S. Hope this is the right place to post this
Sorry, only registered users may post in this forum.

Click here to login