Errors in devkitppc
October 09, 2008 05:55PM
I am trying to compile the demo program that comes with the devkitppc. When I press ALT+1, the bottom of the notepad says "make" it pauses for about 30secs. Then, it says something like
'"/c/documents not found"
"No command to make documents"
"something something [Error 2]"

I have tried to compile freecell and wadmanager. Freecell gives me the same error, wadmanager has a different problem. I do not care about that.

What do I have to do to fix this?
Re: Errors in devkitppc
October 09, 2008 05:58PM
I'm gussing that your project is located under C:\Documents and Settings\etc.? The compiler doesn't like the space in the path; move it somewhere without a space in the path and try again.
Re: Errors in devkitppc
October 09, 2008 06:39PM
I got it working.
Now, I just have to learn hot to code c++.

It shouldn't be too hard. I took a class in VB and /know/ html.

Re: Errors in devkitppc
October 09, 2008 08:46PM
Yeah, the makefile is bugged. They really should fix it.
Yet another case of mixing up the data formats and getting bugs.
Re: Errors in devkitppc
October 09, 2008 10:32PM
Another problem:
"> "make"

> Failed to create process: The system cannot find the file specified.

> Process Exit Code: 0
> Time Taken: 00:00"

Any ideas?
I feel like an idiot.
Re: Errors in devkitppc
October 10, 2008 07:46AM
Is the makefile in the directory that you are calling the make command in, and are all of the files your program need actually there?
Re: Errors in devkitppc
October 10, 2008 03:40PM
The second error sounds like you either screwed up the executable search path or you forgot to install the cross build tools.
Re: Errors in devkitppc
October 13, 2008 09:26AM
I'd advise you to try running 'make' directly from the project directory using a normal cmd.exe shell, then pasting the full error log here.
Re: Errors in devkitppc
November 01, 2008 01:01AM

It took me almost an hour to get the tool chain working to the point that it would compile the "Hello World" .dol file. I've used these tools before for GC years ago. They are very dependent on the correct location of all files needed by whatever you are compiling. Your second error sounds like you are missing files in the appropriate locations.

The problem for me was the installer file (devkitProUpdater-1.4.7.exe) was not downloading the files correctly. I was ending up with only small parts of many of the required files. The installer would appear to unpack the files correctly (no errors) but after examining the folder structure it was obvious that many files were missing. This happened several times on two different Windows boxes.

I ended up manually downloading the required files to a different folder (search on Sourceforge). I ran the installer, and as it downloaded the incomplete files I replaced them with the complete files from the separate folder. The installer then unpacked all of the files to the appropriate folders and made the necessary changes to the Windows environment.

I don't know why the installer was not downloading the files correctly (could be our firewall), but I would check to see if that is your problem.
Sorry, only registered users may post in this forum.

Click here to login