Welcome! Log In Create A New Profile


VBA GX save states

Posted by Hollow_Dragonite 
VBA GX save states
December 04, 2009 01:55AM
On version 2.1.0 of VBA GX, I cant load some save states. I can load save states made on the previous version, but when I resave over it on the new one, then load, it says invalid file format or something like that. Is there any way to fix this, or is it just broken in the newest version? BTW, the previous version had no problems.
Re: VBA GX save states
December 04, 2009 01:59AM
Forgot to mention I've only tried this on The Legend of Zelda: Oracle of Ages
Re: VBA GX save states
December 04, 2009 04:09AM
This appears to be broken, sometimes the VBA GX saves seem to be corrupted. It's the saving and not the loading. A non-corrupted save will never fail to load. But a corrupted save will always fail and never load properly.

It's strange, I recompiled the old versions (2.0.7 or 2.0.8) and the same thing happened on the recompile. So maybe this new bug was brought out by my dev environment - eg: changing from dkppc r17 > r18 > r19? Not sure what to do or how to track this down. :(
Re: VBA GX save states
December 05, 2009 01:34AM
Thanks. I was worried my SD card was broken or something. I hate re-exploring the dugeons if I die, so I'll stick with version 2.0.9. And, since we're on the topic of VBA GX, I was wondering if you could make a way to keep the settings saved. Every time I play a GB or GBC game, I have to change the zoom options so the bottom doesn't get cut off.
Re: VBA GX save states
December 05, 2009 02:49AM
2.1.0 has that feature.
Re: VBA GX save states
December 05, 2009 05:27AM
I've had a similar problem, but it seems like it's gotten progressively worse. I saved a state (I saved over that state repeatedly, but hopefully that shouldn't make a difference), and after loading, it crashed (maybe ten minutes after loading, when I went into the Home menu). Then each time I loaded, it crashed more and more frequently, though not necessarily when going into the menu. It crashed at least once immediately when loading the state. I'm pretty sure this didn't happen prior to updating to 2.1.0, and I updated using the updater within the program, rather than through the homebrew browser. I don't know what of that might help as a bug report, but hopefully some of it does. Should I go back to an earlier version, or just try saving more often and with multiple states?


Also, a few times I've gotten an error message screen that rebooted after 8 seconds (didn't write down the error code, though, and couldn't get it when I actually tried), but other times I get scrambled graphics a sustained tone.

Edited 1 time(s). Last edit at 12/05/2009 05:32AM by jdev.
Re: VBA GX save states
December 05, 2009 09:42AM
Sorry, Tantric. I only used it once, so I didn't know.
Sorry, only registered users may post in this forum.

Click here to login