Welcome! Log In Create A New Profile


The advent of HBC, and how some emulators stopped working

Posted by Magil 
The advent of HBC, and how some emulators stopped working
August 23, 2010 10:16AM
(For those who would like to be spared of most inconsequential and ultimately trivial details, jump almost to the end of my post, after a line of dots, to read the general overview of my problems. If after reading them, you still need details, simply read everything from the beginning).

... so I decided it was time to update HBC. It was alot of fun and all, being at 1.0.6, but the newer version offered so many possibilities that I said: sure, why the hell not? It was true then as it was now that one of the few things that delayed me from updating it immediately in the first place was because of the absent compatibility between Priiloader and the new title ID HBC was given, but I was informed by fellow users there were still several ways to access it in the unfortunate even that I might have bricked (I'm such a paranoid). So anyways...

... I proceeded to install several things before taking that big step. I installed IOS58 using the installer Tantric so gracefully provided us some time ago, as well as the now despised IOS202 v1.1 just for the hell of it (and in case I was ever unsatisfied with the new HBC). After that, I ran the hackmii installer from HBC, uninstalled the now defunct DVDX and proceeded to update both HBC and bootmii (as an IOS T__T). Finished succesfully, reboot and I'm back at System Menu. I fired up HBC and yay: Dark Water theme telling me update was succesful.

Now it was from here on out that I started having several annoying issues: both WiiSX and Wii64 would launch with no problems at all, but they would now refuse to identify my HDD (which they did before updating HBC). In refusing so, I would be unable to load any roms because it wouldn't find any (even though placed in the appropriate paths), or in the case of WiiSX, find the BIOS (also properly stored in the right path). Also worth to note was the fact that whenever I exited to loader, both emulators would flash for a split second after fading to black and before the HBC screen would come up. But that's merely aesthetic in my opinion.

Other emulators with similar problems were Genesis Plus and Hugo GX, which would also refuse to find my roms (again, properly "pathed"... I don't wish to repeat this detail again). However, this issue presented itself WAY before the new HBC was conceived. It ocurred when I migrated all of my apps and roms from a small USB to an HDD (which I hoped would be my single source for all my entertainment media). At the time, I considered looking for any configuration files that I might have missed, and tried copying them over... with no results. Launching both apps from scratch (without any said cfg files) would also yield the same results. And BEFORE updating HBC, I could still continue launching apps from that good ole small USB with no problems. AFTER updating, the USB was not being read by the Wii AT ALL, and nothing would show up in HBC.

Oh, and yes... I tried informing ekeeke (at least to the last 2 emulators, which are really the only ones that concern him). I dropped a couple of lines with the same details I layed here before you in his google codes page, but it was chucked and labeled "denied".

Perhaps the only thing I've left out 'till now has been the presence of 3 partitions in said HDD: the first partition, primary, formatted NTFS, whose contents I wish not to discuss; second partition, logical, FAT32, from where I launch most of my apps (except said emulators) flawlessly and with no trouble at all; third partition, logical, NTFS, where a bunch of mine and my father's personal files are stored for backup (such as family photos, videos, tons and tons of music, etc.).

I've tried to fill in with as much detail as possible. I hope this helps you, the reader, my prospect helper, to help me find out what am I doing wrong and how to fix these issues so I can use only this HDD for apps and whatnot.

... ... ... ...

Now, let's recap and sum it all up in a few lines:

+ Wii64 refuses to identify my rom paths while launching Wii64 from an HDD.
+ WiiSX refuses to identify my rom paths AND bios while launching WiiSX from an HDD.
+ Genesis Plus and HuGO GX refuse to identify my rom paths while launching both apps from an HDD.

Every emulator mentioned in this post was the latest stable release available on wiibrew.org

I thank you in advance for reading this somewhat long post.

- Magil of the Shadows.

Oh, and on completely unrelated side note... remember the small USB I mentioned earlier that once worked flawlessly but then stopped working? It's a generic USB at heart, but it's special to me because it's white all over, with a red LED and had the following print on the side:


How cool is that? It was the first USB that helped me launch apps when I first started using HBC. It actually looked pretty cool when hooked to my Wii, and even more with the red LED that lit up each time my Wii was on. I miss how it worked ever so T__T

Edited 1 time(s). Last edit at 08/23/2010 10:43AM by Magil.
Re: The advent of HBC, and how some emulators stopped working
August 23, 2010 10:34AM
This is very simple: those emulators were released BEFORE the new HBC update, they need to be recompiled to take libogc changes in account regarding USB, the fact they are the "last stable release on Wiibrew" does not mean very much, what matters is the release date.

And FYI, you could have read my comments on your issues and you would have noticed that it got "invalidated" because technically speaking, it's not really an issue with the emulator code itself but the library it is compiled with. I know that from user perspective, it doesn't really matter but your only choices are either to wait for a new release or recompile the code yourself (it's very easy, just follow instructions on the compiling page).
Re: The advent of HBC, and how some emulators stopped working
August 23, 2010 10:41AM
I wasn't meaning to be disrespectful. I merely cleared out the possibilities about what other users might have suggested me to do (i.e. submit this bug to the programmer).

Also (and in the meantime, I guess), would the only current workaround be launching said apps from an SD? I guess I could get a hold of one, or try using a different USB (god knows I have several to spare... though I can't remember which were and weren't working).
Sorry, only registered users may post in this forum.

Click here to login