Welcome! Log In Create A New Profile


SNES9x GX 4.2.4 problem

Posted by max117 
SNES9x GX 4.2.4 problem
September 01, 2010 07:49PM

I used 4.1.9 version before and it was (and it is now) completely ok.
Now I downloaded latest ver (4.2.4) and it shows just black screen and system hangs.

At this time latest version of fceugx works ok. 4.1.9 also works fine.

I use HBC 1.0.8 if that matters and FW 4.1

Edited 2 time(s). Last edit at 09/01/2010 09:21PM by max117.
Re: SNES9x GX 4.2.4 problem
September 02, 2010 06:38PM
HBC is not at much fault here. All of Tantric's latest emulators have a tendency to crash, given that there seems to be an issue on the autoupdater included with his emulators, IOS58 and your Wii not being connected to the internet.

According to several other people's testimonies, it does reduce significantly the chances of Tantric's emulators crashing. It's your choice if you want to connect your Wii to the internet in order to have it working, but my advice would be to simply stay with the old working versions until Tantric fixes this issue, since there also seems to be a dangerous issue in SNES9x regarding it randomly corrupting your HDD or SD card.
Re: SNES9x GX 4.2.4 problem
September 02, 2010 07:27PM
My Wii is connected to internet. I used to autoupdate FCEUGX, but new version also showed black screen, so I had to download it manually from googlecode and it worked alright.
But still latest version of SNES9xGX doesn't work (i downloaded it from googlecode too).
Re: SNES9x GX 4.2.4 problem
September 02, 2010 08:17PM
Then try installing IOS58 if you don't want to update your Wii to 4.3. You can use the Tantric's IOS58 Installer from here:


After you do so, reinstall your HBC channel so it will recognize it and make use of it.
Re: SNES9x GX 4.2.4 problem
September 02, 2010 08:24PM
Hmm... you should post this problem over at the emulator's googlecode page then. You should check if your issue hasn't been posted/solved first though. I seem to have read somewhere there that sometimes the autoupdate feature sometimes downloads incomplete apps, and that's what leads me to think you keep getting black screens.
As you did with FCE, manually download the app from a PC and copy it over to your SD and see if it works now.

In my own honest personal opinion, there isn't anything worthwhile on the latest version of SNES9x. Yes, it's compatible with IOS58, which is said to have USB2.0 speeds, but so does IOS202 (which I feel is much faster than IOS58 anyways). This is only a suggestion, not an order: I'd suggest staying with 4.1.9 if you don't have IOS202 installed, or install it and use the same version I do, which is 4.2.1, which happens to work perfect. Anyways, hope I helped.
Re: SNES9x GX 4.2.4 problem
September 02, 2010 09:41PM
Axel, IOS 58 is installed, and new HBC uses it.

Magil, I saw Tantric here, so I thought I'd reach him here :) I also manually downloaded SNES9x, and I got the same result (fail). I'm staying on 4.1.9, it works fine.

Anyway thanks for Your help! We'll see if Tantric adds something to this post later.

Edited 1 time(s). Last edit at 09/02/2010 09:42PM by max117.
Re: SNES9x GX 4.2.4 problem
September 05, 2010 07:17PM
It's not the app that isn't working. It's the forwarder.

If you load it up from HBC, it runs. Try starting it from a forwarder (Channel forwarder) it freezes.

*Edit* I found a forwarder which works with the current version (4.2.4)
Link: [www.dropbox.com]
It has multiple channel forwarders for the most popular emulators.

Credit goes to troythezombie for updating them and LWares for uploading them.

Edited 1 time(s). Last edit at 09/05/2010 07:32PM by FantaZ.
Re: SNES9x GX 4.2.4 problem
September 05, 2010 08:43PM
Thanks, FantaZ!

I'll try this channels asap. But why new versions of Tantric's emulators don't work when I try to load them directly from HBC?

BTW I've installed 4.3 FW, nothing changed.
Re: SNES9x GX 4.2.4 problem
September 07, 2010 05:04PM
I don't know yet, but i'm eager to find out why. Corrupted files maybe because they work fine on my machine.
Or it's your firmware. I'm running 4.1E

Not the best option to update to 4.3 ;)

Edited 1 time(s). Last edit at 09/07/2010 05:06PM by FantaZ.
Sorry, only registered users may post in this forum.

Click here to login