Welcome! Log In Create A New Profile


VBA GX Won't Save

Posted by Vidus 
VBA GX Won't Save
August 20, 2015 10:54PM
The Save features in VBA GX does not work correctly for me. I'm refering to save files (.sav) and not save states. Whenever a game is opened it creates a new ".sav".

<>I have tried versions 2.0.9, 2.1.9, 2.2.5 - 2.2.8
<>I have tried from fresh/clean installs.
<>I have tried it on other SD cards.
<>I have doubled checked that SD cards aren't in Read Only mode.
<>I have double checked that files & folders on the SD aren't Read Only.
<>I have tried toggleing all combivations of "Auto Save/No" and "Auto Load/No" of "SRAM".
<>Auto Loading and Auto Saving of Save States work fine.
<>Manually creating a Save File and Manually loading a Save File does not work.
<>It seems that the "game_name [Auto].sav" is always newly created when the game is loaded.
<>There are no issues with FCEUltra GX or Snes98 GX.
<>GBA and GBC games .sav are fine.

Example Procedure for Error.
0. Auto Save - SRM; Auto Load - SRM
1. Load game.
2. Save game.
3. Press Home. Select New SRM.
4. Press Home, return to game. Soft reset (A+B+Select+Start). Game is OK.
5. Press Home. Press Home, return to game. Soft reset (A+B+Select+Start). Game is OK.
6. Press Home. Select Main Menu. Load game. Completely new SRM.
7. Press Home. Select SRM from #3. Completely new SRM.

Further testing:

It seems that older GB (brick) games are the ones that don't save. Namely Final Fantasy Legend, Final Fantasy Adventure, and Ultima: Runes of Virtue. Newer GB (brick) games such as LoZ: Link's Awakening (not DX) and Final Fantasy Legend II save fine. *grumble grumble*

Any other things I could try to resovle this issue? Has anyone actually resolved this issue? Thank you.

Edited 5 time(s). Last edit at 08/21/2015 03:28AM by Vidus.
Sorry, only registered users may post in this forum.

Click here to login