Welcome! Log In Create A New Profile


Wii Bannerbrick? Priiloader 0.6 installed

Posted by yskysk 
Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 03:29AM
Wow what a mess. I tried to manually install Ios 58 to get my usb keyboard to work. I would've used Tantric's ios 58 installer but I don't have an online connection for my wii. Following the discussion on that page however I installed Nus downloader, worked out the ID for IOS 58 as 000000010000003A v6175, then got wad import to install the wad (I didn't set the patch option).

I used Bootmii to create a new backup of my nand before attempting to install the wad. Backup proceeded fine and I installed the wad which seemed to run as planned as well. Taking note of Tantric's message to reinstall Homebrew channel in order to recognize the new Ios, I tried to reinstall HBC through Bootmii. I ended up having two versions of the HBC on the system menu page, one version 0.8 the other 0.6 that I had earlier accidentally left on the SD.

I decided to delete the 0.6 channel through the wii setting menu and then copied a newer version of the hackmii installer .elf file to the root of the SD card (renaming the 0.6 HBC old.elf to keep it to one side). I whacked that sd card into the wii, hoping to reinstall HBC 0.8, ios 58 present with my usb keyboard ready to go. Then... disaster.

Priiloader started up stating there was an error booting HBC, maybe the title was not installed.

I tried going to the system menu but got a glitchy message from the wii saying the:
"System files are corrupted. Please refer to the Wii operations manual for help troubleshooting" Knowing there was not much information on Priiloader in the operations manual I decided to reboot Priiloader and enter the Bootmii menu. I thought if I had the nand files I could just start again, right? Well one of the menu options gave an error message trying to read the card and when I entered the sub-menu to upload the nand to the wii it said something like boot ios not found with a warning that it was dangerous to proceed. Slightly panicked, I decided to exit.

I entered Priiloader again with copies of the nand on two sd cards in case the original was faulty. Tried to enter Bootmii again but this time it gave me a message "could not find fat:/bootmii/armboot.bin" and then "error booting bootmii ios" Non-plussed at the prospect of owning a shiny white brick, I tried the other priiloader options to try and get anywhere.

I selected the load file option and incredibly (at least for me) the hackmii installer screen came up. Not sure what to do at this point I uninstalled HBC and went to exit. Hackmii installer exited to the wii system menu, behaving like it always did. (what the hell is going on?) Anyway. I shutdown, re-entered the hackmii installer with Priiloader's install file option, and reinstalled the HBC and exited into the HBC (it appears to be version 6). From the HBC i can return to the wii system menu but If I try to enter Bootmii the system freezes and my dvd drive flashes.

So now I'm considering reentering the hackmii installer and reinstalling (?) bootmii 'as an Ios', in order to upload the nand and (hopefully, hopefully) get a complete system restore. So I thought I'd ask for some guidance/ advice instead of taking any more chances.

I'm using Priiloader 0.6 on iosv60 system menu v418
HBC v0.8 (now v.06)
Wii 4.0E
Hackmii readout is 1.0.3 ios 61 v19.26
'Bootmii can only be installed as an IOS. The installed boot 1 version prevents a boot 2 install.' I can install bootmii as an ios and it asks me to prepare an sd card.

If you can help I'd greatly appreciate it.
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 11:39AM
the flashing drive means bootmii ios (mini) couldn't find the files on SD (sd:/bootmii)
the installer can place those files on the SD if needed
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 01:58PM
Thanks I added the missing files and bootmii will now load. I am still receiving the same "dangerous to proceed" message when I attempt to upload my nand backup (does it need to be on the same sd card with the rest of my programs?). Anyway by selecting a boot.elf file from the apps folder while using priiloader I'm able to start hackmi > and exit into HBC v0.6. The usb keyboard works now (i guess ios58 was installed successfully then) but using programs like Tantric's emulators will not load up for some reason (frodo does work however)

I decided to update hbc to v0.8 through HBC 0.6 and it installed no problems. Then when I selected a program through HBC the screen froze. I restarted the wii, It was stuck on a black screen for the longest time, then HBC v0.8 actually booted, but without icons or the pointer hand. I can get back into HBC 0.6 through an installed file with Priiloader but still certain programs won't work (are they the ones that require libogic? Would it be missing for some reason.) Thanks in advance for any further suggestions.
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 03:43PM
Well shifting the contents of the hackmii folder and the private folder on the root of the sd card has gotten rid of the flawed Nintendo system corrupted message and I can now power on to the system menu without problem. Seeing I had 2 HBC's on the system menu,

I decided to uninstall one and delete the channel of the other in order to start afresh and reinstall HBC 0.8 The only thing now is I can only install HBC v0.6. If I try to update it to v0.8 the system hangs at the start to the hackmii menu (the 'press 1 to proceed' message never appears). The other thing is many of the applications I use under HBC no longer work. Sms plus, gensgxplus and c64.org (frodo), among many other emulators work fine but others such as SDLmamewii and all of Tantric's emulators just load to a black screen. Wiimc loads up but displays a message that the ios I'm using (ios58?) is not supported and may make the system unstable.

So I'm not sure how to proceed. I'm guessing the unsupported IOS problem in Wiimc is causing some programs to not function at all and for HBC0.8 to hang during update/ install. What's the best course of action to take?
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 03:50PM
wiimc gives that because its using an IOS that isn't 61 or 58.

run a syscheck and post the results here (even though i have a good guess whats going on; a syscheck can never hurt)

Edited 1 time(s). Last edit at 04/23/2011 03:50PM by dacotaco.
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 04:06PM
Ok. Syscheck crashes to Bootmii about half-way through checking IOSes for vulnerabilities. The only information I can get from the saved file is:

Region: PAL
The system menu v418 is running under IOS36 (rev 3351)
Hollywood v0x21

Boot2 v4
Found 50 titles
Found 23 IOS on this console
Found 9 IOS Stubs on this console.

Thanks for replying.
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 05:10PM
euh...what syscheck are you doing? using what program?
i recommend dop-mii to do it
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 05:23PM
I used this one Syscheck, Dop-mii generates this report:

Region Europe (E)
Hollywood Version 0x21

IOS Version FakeSign ES_Identify NAND Flash
61 (v4890) Disabled Disabled Disabled Disabled
60 (v6174) Disabled Disabled Disabled Disabled
58 (v6175) Disabled Disabled Disabled Disabled
56 (v4890) Disabled Disabled Disabled Disabled
55 (v5149) Disabled Disabled Disabled Disabled
53 (v5149) Disabled Disabled Disabled Disabled
38 (v3610) Disabled Disabled Disabled Disabled
37 (v3612) Disabled Disabled Disabled Disabled
36 (v3351) Enabled Enabled Disabled Disabled
35 (v3092) Disabled Disabled Disabled Disabled
34 (v3091) Disabled Disabled Disabled Disabled
33 (v2834) Disabled Disabled Disabled Disabled
31 (v3092) Disabled Disabled Disabled Disabled
28 (v1293) Disabled Disabled Disabled Disabled
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 09:41PM
start all over again

delete ios58
delete any HBC installed (keep bootmii and priiloader)
reinstall IOS58 (with a new wad; dont use the old one. or use dopmii)
install HBC over again using the latest hackmii (http://bootmii.org/download/)
if it still freezes check the installer.log on your SD
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 23, 2011 09:58PM
Will do, thanks alot.
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 24, 2011 02:50AM
I got it working back to normal thanks very much! I uninstalled HBC then removed any traces of HBC 0.6 from the sd card. I then used Any title deleter to delete Ios58 and was able then to install HBC 0.8. I tried to install another version of Ios58 and although it worked better ( HBC 0.8 continued to run, dosboxwii had keyboard support, although c64.org didnt) It had a few negative side effects (Caused wiimc and c64.org to crash, probably among others). So I've uninstalled Ios58 for the time being until I find another copy/ version or different method of installation (i might try dopmii (wii. ed) instead of wad import).

I found that having priiloader set to boot HBC when it's corrupted or didn't exist led to the Priiloader screen appearing on startup. Selecting to go to the system menu from Priiloader after that error mesage displayed was what was causing the wii 'file system corrupted" message. I don't know if that was a banner brick and it seemed pretty bad at the time but it was made kind of trivial with the assistance of priiloader (whether it caused the error in itself I don't know, but regardless). You shouldn't press home without it. Thanks again.
Re: Wii Bannerbrick? Priiloader 0.6 installed
April 24, 2011 11:57AM
i do recommend to install IOS58 and reinstall HBC 0.8 afterwards so that HBC will use 58

but the choice is yours ofc :)
Sorry, only registered users may post in this forum.

Click here to login