Updated Wii Yesterday. I Deleted HBC. Can't get it back.
May 13, 2011 05:30PM
A few days ago, I updated my Wii through Nintendo. I had a functioning homebrew install prior to this. After the update, either the HBC itself would crash out or some of the apps would not load. I can't remember which case it is. I tried to reinstall HBC--not sure what methods I used. I know everything was done through priiloader. If this sounds strange to you, I assure you it's because of mental health problems who's treatment leaves me with a very bad short term memory.

With that being said, through pure negligence, I may or may have not performed an illegal modification to my wii while trying to recover my homebrew. I am not be snarky, I just can't remember what I did. I was following any kind of guide that would get my homebrew back. IOS files have been modified--if that's illegal, please don't ban me, I have no intent to be a pirate or anything other than a "law" abiding person.

- Wii is not "bricked" as far as I know by my understanding of the term. System menu 4.3U loads fine. All my regular channels including disc channel work.
- I deleted HBC in an attempt to reinstall, so I have no HBC.
- Priiloader works. Bootmii appears to work, but I cannot restore my nand backup--some kind of error message starting with "Try harder..."
- Most homebrew apps do work thru priiloader-->wiiexplorer.

I have tried running hackmii through priiloader to try and reinstall HBC, but it errors out. I'm aware I haven't provided enough information here, but I haven't homebrewed a Wii in a long time, and my memory/cognition issues are preventing me to help troubleshoot this thoroughly. Any input is greatly appreciated. Please don't ban me, I'm just an "idiot" with no intent for malice.
Re: Updated Wii Yesterday. I Deleted HBC. Can't get it back.
May 13, 2011 11:56PM
Two things you could try:

1. Loading HackMii Installer with wiixplorer
2. Loading "bootmini.elf" with BootMii - either through the SD option in the BootMii menu, or if that fails, by replacing "ppcboot.elf" in the "BootMii" folder on your SD card with a renamed copy of "bootmini.elf" (backup the original "ppcboot.elf" first, so you can run BootMii again once you're done)

The reason you can't install a NAND dump with BootMii is because you have BootMii installed as IOS instead of as boot2 - this is most likely all that is possible on your Wii, and it is highly inadvisable to restore a NAND dump with BootMii as IOS. It can be done, but I won't tell you how as it is a practice I feel is a very bad idea - there is always a better way to fix the Wii if you can access BootMii as IOS.
Re: Updated Wii Yesterday. I Deleted HBC. Can't get it back.
May 14, 2011 12:55AM
Thanks for the reply. I don't know what the guy below me is talking about.

Edited 2 time(s). Last edit at 05/14/2011 07:47AM by Cuddle.
Re: Updated Wii Yesterday. I Deleted HBC. Can't get it back.
May 14, 2011 02:49AM
Yup don't link there; that's got lots of stuff you shouldn't mess with. I'm glad you got your problem solved though.
Sorry, only registered users may post in this forum.

Click here to login