Welcome! Log In Create A New Profile


wankynono's Battle Aftermath

Posted by Magil 
wankynono's Battle Aftermath
September 24, 2010 08:32AM
This post is related to this, much older post, regarding a problem that came up with me friend's Wii: [forum.wiibrew.org]

After restoring his Wii to a functional state, there has always been one problem bothering my friend, and that's being unable to get his Wii connected to the internet (for this same reason, he's been unable to use WC24... but that's implicit). He keeps getting Error 101246 every time he's required to test his connection.

A quick google search later only reveals results from gbafail's forums... though they seem to be the only one's that vaguely address this problem. Their general diagnostic consists of there being a corrupt save file on the system, which the connection test finds and then refuses to connect. I dunno if this is true or not, but given that every other site on the net seem to hold this true and reference gbafail as the source of their knowledge...

Anyways, what do you guys think about this problem? My friend went on a channel deletion spree (using ATD for said process) and killed everything except HBC and Disc Channel. He also formatted his Wii, wiping out any possible corrupt save... but it still keeps getting the same problem. On top of that, he complains of the speed his Wii works at (takes about 1 minute or 2 to load WW/VC/disc based Wii games, and another while to load the save).
Re: wankynono's Battle Aftermath
September 24, 2010 04:13PM
Nintendo doesn't give any information beyond noting that its an error related to online play: [www.nintendo.com]

Based on what you're saying I'm going to guess that it's an error with you internet set-up.

I'd like to know do you have any problems connecting to the internet in homebrew? If not, then I'll have to go back to the drawing board.

Regarding "the speed at which the Wii works": The Wii's hardware in general is pretty crappy. Just be happy that the Wi even works after the complete recovery you described.
Re: wankynono's Battle Aftermath
September 24, 2010 09:42PM
Briefly speaking off-topic... wow, did you notice you hit 5000 posts? Heh. Umm... congrats? Ok, back to topic...

Nope. He can't get any homebrew connected to the internet because of what I already posted: when required to use the mandatory connection test, it fails and spits out that error. Unless my friend is holding something back... but he says he can't get his Wii connected because it fails just this one test.

I would recommend reading a bit on gbafail's related posts to give you an idea of the situation... it's pretty frustrating, because there seems to be something behind the scenes messing with the Wii.

After a good night's sleep, I strongly believe there IS a corrupt save file. Why? Because just yesterday, while playing FF IV on SNES9xGx, my HDD disconnected just as I was saving my game. This led to my save being corrupted, and my Wii hanging each time I tried to load this game (because it also wanted to fetch the corrupt save). When I looked at it from my laptop, my laptop would also hang... and trying to copy the entire save folder to some place else on my laptop would only tell me that the sector where my FFIV save was placed had become corrupted. I couldn't even delete the save because Windows didn't know what to do... until I repaired the entire partition. Then I thought I could salvage that save... but alas, it didn't and I shed a tear. But at least I could then delete it and start over with no issues.

It sounds unrelated, but I think that since I had a corrupted save on a HDD and even my laptop started to act all funky when trying to read it... maybe the Wii is having trouble with a corrupt save of it's own?

Now, this is my theory: since my friend's Wii (and every other Wii with the same problem) present the same symptoms, like not being able to connect to the internet because it fails the mandatory test, extreme slow down while attempting to load ANY game... I think it's Nintendo's way of preventing the user from bogging down his and other player's netplay experience. Since that save might have other players waiting for his Wii to unusually load slowly, Ninty simply excludes him until he sorts out any issues with his Wii.

This last bit was spoken out of speculation. Feel free to add your thoughts.

Edited 2 time(s). Last edit at 09/24/2010 09:45PM by Magil.
Re: wankynono's Battle Aftermath
September 25, 2010 01:41AM
But you said he already formatted his Wii? Didn't he? Then I don't see how that hypothetical savegame could still remain in his system.

There is no way Nintendo can remotely affect your Wii to make it work slower, not it can prevent it from connecting to the internet. How can they achieve something like that if the Wii can't even get online?

My theory is a little different from yours... your friend has badly screwed his Wii affecting its hardware beyond just software problems.
Re: wankynono's Battle Aftermath
September 25, 2010 02:35AM
That's exactly why I encouraged for anyone reading this topic to read gbafail's threads on the matter. Also, and let me strongly emphasize: THIS IS NOT MY WII. It's a friend's Wii, as I stated in the ole' bricked thread I linked in my first post, and every post after that. My Wii is working just fine.

Back to topic... I haven't implied that my friend's Wii has ever connected to the internet after he fixed his brick. But since I seem to not be getting the point across (I do ask you to bear with me... I might be fluent in the english tongue, but it's not my native language and sometimes I might end up writing stuff that while litterally translated to spanish, it makes alot more sense...). I'll resume my friend's problem in the following points:

- Friend's Wii goes to Wii settings, goes into Internet Settings, setup Wii for his local wifi network, inputs password, Connection test
- Friend's Wii errors out with 101246. Connection to internet failure

My friend's problem, again, in a few points:

- When internet is setup, mandatory connection test ensues.
- Supposedly (and according to various gbafail reports), when connection test is running, Nintendo's servers scan for any corrupt save files.
- If no corrupt save files are found, System Update prompt is given (if any available) or no message at all (???); If corrupt file save found, error 101246, no internet for Wii =(

My theory, in a few points:

- Nintendo performs said scans to prevent people with faulty saves going on Nintendo's servers for netplay (why? I explained why in my previous post. And that is also part of my theory.)

Now... if an entire system format was performed and still has not solved my friend's problem, why should I still support the idea of a corrupt save, if none appear on the Wii's save manager? That was also pointed out in gbafail. Basically, it said there were still traces of the corrupt save left behind that could only be viewed by navigating to said directory using Dop-Mii MOD ande erasing those manually (haven't told my friend to do so, and I don't plan to tell him where in the damn NAND are saves located... just to be safe). They were SUPPOSEDLY there, but not much on that particular topic was ever discussed further, since the guy with the problem apparently solved it by tracking down the corrupt save (he knew which one was corrupt in the first place) and forcefull replacing it various times with a healthy save, then finally deleting it.

Another guy on the net with the SAME problem simply went ahead and converted a friend's NAND dump so he could use it on his Wii.

I dunno if I explained myself clearly this time. But if something here was not understood correctly, please ask and I'll try to rephrase what I wrote in more clearer words, instead of asuming stuff.

I would like to solicit permission to post said links here, just this once. If not, well... please google them.
Re: wankynono's Battle Aftermath
September 25, 2010 03:12AM

Has he tried to connect to the internet with out a secure connection? What I mean is, I tried to connect mine, even with a password it wouldn't work, so I had to kill my secured wifi at home and the wii right off the bat connected to it no problem. With my wifi being secure it would keep giveing me problems, could this be what he is haveing with his wii. Only reason I ask this is you said he can't even connect with the homebrew browser.

Who said that nintendo forces a scan when you do internet test to check said wii's for things and then to keep it from being connected to internet because of bad things, to me this could be wrong, for one there is the internet channel, and two what would be the point of haveing a wii with internet channel it won't connect to get online. To me it sounds like there is a security issue in his wifi, the wii's wifi software parts, or hardware parts could be corrupt not letting it connect. Just a thought.
Re: wankynono's Battle Aftermath
September 25, 2010 03:45AM
Well, he was just called from work for an emergency something something, so I don't think he'll get anything done today. Anyways...

I doubt it has something to do with his router. And I doubt it's also something to do with his wifi-card. As implied in the brick repair process thread, he WAS connected to the Wii before bricking and was able to use Dop-Mii to repair his System Menu. It was only when he was asked to format his message board that he was able to get back into the System Menu, but it seemed that his settings got also killed off in the process... so when he went to check his Wii internet settings, they were back to default.

However, I'm not prepared to fully discard the whole "router" possibility, so I'll ask him to drop password on his network as soon as he's available.
Re: wankynono's Battle Aftermath
September 25, 2010 03:58AM
Could it be possible that he may need to reformat it again, could it have gone bad and missed some stuff or it skipped that part? This happens if you install software on PC's sometimes you need to reinstall to get it fully installed, if that makes sense.
Re: wankynono's Battle Aftermath
September 25, 2010 06:30AM
Formatting through the system settings does not actually format the NAND file system. If deletes some things and that's about it. It is quite possible that there is some system file left that would not be removed by the format. Also, I doubt that this is hardware failure.

Do any unusual hidden channels, IOSes, or anything else that would not normally be on on a wii appear in AnyTitle Deleter? I assume he already took care of this, but I still have to ask.

If nothing else works, install Bootmii/boot2 and then use Comex's NAND formatter. That almost certainly will fix it. Of course, you must find a build of the formatter that actually formats the NAND (some builds only install WADs). However, if this wii has boot1c+, I don't recommend you try this.

You can also play around with FS Toolbox and see if there is anything unusual on the NAND compared to another wii. Just remember that FS Toolbox is a ticking time bomb. Using it without Bootmii/boot2 may be suicide.

Edited 1 time(s). Last edit at 09/25/2010 06:32AM by jbc007.
Re: wankynono's Battle Aftermath
September 25, 2010 05:38PM
Sounds like that stupid "make network test always fail" preloader hack is turned on.
Re: wankynono's Battle Aftermath
September 25, 2010 08:48PM
is there another preloader 'make your Wii run sluggish' hack? xP
Re: wankynono's Battle Aftermath
September 26, 2010 11:57PM
Ok, I'm back with news...

When I said format, I didn't mean flashing the NAND and starting from zero. I meant using the Wii's built in Format option found somewhere in the Wii's settings. I know it only kills off saves and channels. But anyways...
Since he has no bootmii as boot2, using FS Toolbox was obviously out of the question. Instead, I had him navigate through his system files using AnyTitleDeleter MOD, and had him give me a list of all titles that appeared.

From what I could tell, there was really only one title that seemed out of place:

00555045 (.UPE) : UNKNOWN

I tried looking it up with my good friend google, but couldn't find any information about it. Could this be it? Any info would be most appreciated.

Oh, and about Priiloader, the only hacks he has enabled as far as he knows are the "block disc update" and "no health screen" hacks.

Edited 1 time(s). Last edit at 09/26/2010 11:58PM by Magil.
Re: wankynono's Battle Aftermath
September 27, 2010 01:27AM
It is possible that there is something wrong with the Priiloader hacks; try disabling them. I have no idea what that title is, and I suppose it could be the problem. I certainly don't see how deleting it could cause any (major) problems.
Re: wankynono's Battle Aftermath
September 27, 2010 09:58PM
00555045 (.UPE) : UNKNOWN
I tried looking it up with my good friend google, but couldn't find any information about it. Could this be it? Any info would be most appreciated.
That's from a disc used at the factory, there was a hackmii post that mentioned that titleID.
Re: wankynono's Battle Aftermath
September 27, 2010 10:37PM
Well... at any rate, and since I took jbc007's word for it... the last thing I told my friend was to go ahead and delete that title. Well, not exactly an instruction... I told him that it might NOT do any harm, but then again it MIGHT, but since there was no more info around available around this title, it was relatively "safe" to delete. He told me he would think about it... and that was yesterday.

Haven't spoken to him since, and I'm still waiting for him to log in to ask how everything went.

I received from him a list of all titles listed by ATD MOD, and that's the only weird thing I found while searching. Maybe I missed something? He also sent in some photos he took from the TV while browsing with ATD. If anyone wants to take a look at them, please do so and I'll upload them for my next post.
Sorry, only registered users may post in this forum.

Click here to login