Welcome! Log In Create A New Profile


Strange problem with emulators/apps

Posted by seersixone 
Strange problem with emulators/apps
April 07, 2013 04:15PM
Edit: I left out some important information from my problem, mainly the Wii I am actually using. I have a red Wii, the one from Mario's 25th anniversary which came bundled with New Super Mario Bros. Wii, Wii Sports, and the Red Wii Remote and Nunchuck, which means that BootMii could only be installed as an IOS. I don't remember if I had installed it or if it failed, but I do remember formatting the SD Card after installing the Homebrew Channel, which means that I have never used BootMii (I had no idea that I needed the SD Card files to use BootMii, so I deleted them).

The reason that I bring my problem here instead of the emulator sites is because they are too similar, which makes me think that the problem is with my SD Card, the SD Card slot, or my Wii.

Hi, I am having a strange problem with all of the emulator apps that I am using. I am using a SanDisk 4GB Micro HC card, which according to the compability list of sd cards, is supposed to work fine. I soft-modded my Wii a year ago using Letterbomb, 4.3U. I did not use bootmii correctly either, didn't do a NAND backup and even deleted it without attempting to use it right. The only thing I have is the Homebrew Channel.

Before listing my problems, I will say that my Wii must have a problem with its internal battery, since if it is inactive for a couple of days, the internal clock of the wii will change. Could this cause problems to the SD Card slot? I have also read that the wii is not a good Micro HC SD Card reader. Is the Wii damaging my SD Cards? I am beginning to think so, since sometimes, the Homebrew Channel fails to see the apps unless the card is removed and re-inserted. I am now going to list the problems with each emulator.

FCEU and SNES9x: When the emulator opens, it says that there is an error in the directory, but I can still access the roms. After playing a game, when I attempt to load another one, the rom list dissappears and I cannot access it, as if the sd card is not inserted.

GENSPLUS: Originally, it didn't boot, but it was because of not placing all of its folders within the app folder. Now it is similar to the above emulators. I can play a game and the screenshots on the game list appear fine, but after playing a game and attempting to load another one, the game list either, dissapears, or the screenshots dissappear, and the emulator is unable to load any games.

MEDNAFEN: I use this to play Turbografx games. Though the roms are on the list, the emulator is unable to load them, but they work on my pc in other emulators.

WII64: Similar to the FCEU and SNES9x, I can load a game, but if I want to play something else, there will be a single game in the list with unknown characters. When I load this game, it is the same game I was playing previously, but the game doesn't boot. I can exit the emulator by pressing the power button on my Wii remote.

RETROARCH: Doesn't load any games, even though it did before. Some games even dissappear.

MAMEWII: I can see the game list, but the games load slower, and nothing shows up once the game loads. The emulator happens to crash I believe.

So what I am wondering is, is my SD Card Slot damaged? Did it damage the SD Cards? Could something else have damaged them? Did the internal battery of the Wii damage the SD Card slot? I am probably asking too much, but I will appreciate any help and thank whoever helps me in advance.

Edited 1 time(s). Last edit at 04/08/2013 02:56PM by seersixone.
Re: Strange problem with emulators/apps
April 15, 2013 02:55PM
Sorry for the double post, but I tried using the apps, this time with an USB Mass Storage Device, but I ran across more problems with it. I could load a rom in some emulators, but then the emulators would hang. It seems that the Wii SD Card slot and the USB slots are damaged. I gave up then.

I then tried one last time to insert an SD Card to use Letterbomb to uninstall the homebrew channel, and it worked. It also allowed me to unninstall BootMii as an IOS. I did that without knowing if it was a good idea, so now I insert my Mario Party 9 disc, and it is asking me to update. But I am on 4.3U still, does it have something to do with BootMii and the IOS? Should I update?
Re: Strange problem with emulators/apps
April 15, 2013 03:32PM
Triple post, sorry. I went to the IRC channel and got the problem solved. A lot of people saw this post, which must mean that a lot of people tried to help, but had no idea what the problem was. So I will thank all of you for that. And I'll thank Candice a fourth time for helping me. I'll see if I can lock the topic.
Re: Strange problem with emulators/apps
April 15, 2013 05:56PM
Try to avoid double posting by editing instead.
Re: Strange problem with emulators/apps
April 16, 2013 06:52AM
It's all good, I'm glad you found a solution.

Sorry, you can't reply to this topic. It has been closed.