Welcome! Log In Create A New Profile Wiibrew Wiki HackMii Blog

Advanced

Updating the Forum Rules

Posted by Arikado 
Updating the Forum Rules
August 14, 2010 09:18PM
Re: Updating the Forum Rules
August 14, 2010 11:17PM
I read all that and don't understand some of it. So with this new rule does the dop-mii get changed so it doesn't patch any ios? Some of this sounds so confusing and complicated. Does it make some apps not work or will they still work, just now somebody creates a app it has to be able to run on a IOS and not a patched one? Can be a discussion on this to get a better understanding for some of us that might now understand it?
Re: Updating the Forum Rules
August 14, 2010 11:25PM
Re: Updating the Forum Rules
August 14, 2010 11:36PM
Ah ok so dop-mii for example wouldn't be able to be discussed since it patches ios's unless its reworked to not patch ios's and like the TBR those can't be discussed? So this is the reason for haveing IOS 58 then and delete ios 202 or is that just for the usb update for storage devices? It sounds confusing and complicated and sounds bad when I read through it all.
Re: Updating the Forum Rules
August 15, 2010 12:38AM
Under the new rule (I'm quoting myself here):

"Any application which requires a patched IOS to use or which grants users functionality to patch IOSs will be strictly prohibited throughout the WiiBrew Forum."

Since DOP-Mii requires a patched IOS to use, it is (as sad as I am to say it) strictly prohibited from discussion within the WiiBrew Forums.
Re: Updating the Forum Rules
August 15, 2010 04:58AM
May I, to put it bluntly, ask why?
Re: Updating the Forum Rules
August 15, 2010 08:24AM
because patched ios are deemed unnecessary and unstable
Re: Updating the Forum Rules
August 15, 2010 05:55PM
Re: Updating the Forum Rules
August 15, 2010 06:58PM
jbc007:
I wrote that overlooking that there are very old vanilla IOSs in existence that had the trucha bug, ES_Identify, and NAND permissions in them. To that end, I redact my comment. Discussion of Savgame Manager MOD and Priiloder will only be allowed if discussion does not advise users to patch their IOSs.

Thank you for catching my mistake.
Re: Updating the Forum Rules
August 15, 2010 07:32PM
Re: Updating the Forum Rules
August 15, 2010 08:32PM
Going off of what dacotaco said; Myself and other developers are indeed working on developing new tools which do everything the old tools did without patching IOSs. Example: Installing content with any vanilla IOSs, a savegame manager that runs on all vanilla IOSs, priiloader installtion any of the vanilla IOSs.

So don't think that some functions of homebrew will be forbidden here forever ;-)
Re: Updating the Forum Rules
August 16, 2010 02:07AM
Sounds good. I never really cared for patched IOSes, as the only non-piracy applications that need them are those hard coded to use cIOS 202 or 249, and of course DOP-Mii, which only seems to work right when running on cIOS 249. This will definitely be an improvement in the end; however, it may be a pain for many users until applications are updated to not require IOS exploits.

Possibly the biggest issue with this new policy is that it will greatly reduce the usefulness of the FixMii section. I don't have time to think of and explain every single situation where this will be the case, but the most significant ones I will detail below:
1) At the moment, no applications have been updated to utilize the AHBPROT flag. Furthermore, it is possible that some never will be updated (AnyRegion Changer and System Setting Replace MOD seem like good examples). Such applications are critical for recovery from certain issues.
2) Applications launched through Priiloader can not utilize the AHBPROT flag. Even if Priiloader is updated to set the flag, many people will fail to update Priiloader for quite a while.
3) Sometimes it will violate the rules to tell a user which application to use to use to fix a bricked wii. After all, System Setting Replace MOD was, on occasion, a useful tool despite the fact that it required cIOS 249.

Finally, although it is entirely possible to update system channels by downloading them with NUS Downloader and installing them with a WAD installer, this is quite a pain. This was really the only purpose of WiiSCU, as having it patch the IOSes it installs has always been completely pointless. I'm not even sure whether the IOS patching feature works, as I tried it once but those supposedly patched IOSes were reported as unmodified by the Hackmii Installer and they did not accept fake signatures.



Edited 3 time(s). Last edit at 08/16/2010 02:23AM by jbc007.
Re: Updating the Forum Rules
August 16, 2010 07:35AM
Re: Updating the Forum Rules
August 17, 2010 04:55PM
Is BootMii an exception to these new rules?

As of HackMii Installer 1.0.8 it will always install BootMii as a cIOS in order to enable installation of HBC.
Re: Updating the Forum Rules
August 17, 2010 09:54PM
Of course BootMii is an exception. It is not like a regular cIOS, it allows you to use MINI.
Re: Updating the Forum Rules
August 18, 2010 07:55PM
BootMii isn't a cIOS IMO. This is of course debatable, but generally a cIOS is simply a patched version of an official IOS. BootMii/IOS is simply a loader for MINI, and is completely custom. MINI Is Not IOS (that's what MINI stands for), but if you think about it, its really the only TRUE cIOS, as it is 100% custom and replaces IOS.
Re: Updating the Forum Rules
August 19, 2010 02:30PM
Re: Updating the Forum Rules
August 26, 2010 02:52AM
I don't understand why you guys keep eliminating good homebrew. I mean I get not allowing the piracy apps, but dop-mii is a very useful tool.
Re: Updating the Forum Rules
August 26, 2010 03:12AM
Re: Updating the Forum Rules
August 26, 2010 03:37AM
Sorry, you can't reply to this topic. It has been closed.